Changes between Version 1 and Version 2 of TracUpgrade


Ignore:
Timestamp:
2006-09-10T02:41:18+02:00 (8 years ago)
Author:
trac
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • TracUpgrade

    v1 v2  
    2121to install the new version. If you've downloaded the Windows installer, you execute it, and so on. 
    2222 
    23 In any case, if you're doing a major version upgrade (such as from 0.8 to 0.9), it is ''highly'' recommended that you first remove the existing Trac code. To do this, you need to delete the `trac` directory from the Python `lib/site-packages` directory. You may also want to remove the Trac `cgi-bin`, `htdocs` and `templates` directories that are commonly found in a directory called `share/trac` (the exact location depends on your platform). 
     23In any case, if you're doing a major version upgrade (such as from 0.8 to 0.9), it is ''highly'' recommended that you first remove the existing Trac code. To do this, you need to delete the `trac` directory from the Python `lib/site-packages` directory. You may also want to remove the Trac `cgi-bin`, `htdocs`, `templates` and `wiki-default` directories that are commonly found in a directory called `share/trac` (the exact location depends on your platform). 
    2424 
    2525=== Upgrade the Trac Environment === 
     
    5454The following sections discuss any extra actions that may need to be taken to upgrade to specific versions of Trac. 
    5555 
     56== From 0.9.x to 0.10.x == 
     57 
     58Due to some changes in the Wiki syntax, you may notice that certain parts of your pages no longer work as expected: 
     59 * Previously, links to images would result in that image being embedded into the page. Since 0.10, links to images remain plain links. If you want to embed an image in the page, use the `[[Image]]` macro. 
     60 * You can no longer use `%20` in wiki links to encode spaces. Instead, you should quote the name containing spaces (for example, use `wiki:"My page"` instead of `wiki:My%20page`.) 
     61 
     62== From 0.9.3 to 0.9.4 == 
     63 
     64There is a bug in Pysqlite 1.x that causes reports using the "%" character for `LIKE` clauses or date formatting to fail.  You will need to use escape the percent characters with another: "%%". 
     65 
     66== From 0.9.x to 0.9.3 or later == 
     67 
     68If you are using plugins you might need to upgrade them. See http://projects.edgewall.com/trac/milestone/0.9.3 for further details. 
     69 
    5670== From 0.9-beta to 0.9 == 
    5771 
     
    8397}}} 
    8498 
     99To update multiple database files at once on linux you may use the following command (replace {{{/var/trac}}} withe the location where your trac installtions reside): 
     100{{{ 
     101 $ find /var/trac/ -iname "trac.db" | xargs -i bash -c "mv {} {}.2; sqlite {}.2 .dump | sqlite3 {};" 
     102}}} 
     103 
     104Remember the give the webserver write permission to trac.db. 
     105 
    85106After testing that the conversion was successful, the `trac2.db` file can be deleted. For more information on the SQLite upgrade see http://www.sqlite.org/version3.html. 
    86107