Opened 8 years ago

Closed 7 years ago

#87 closed defect (wontfix)

Zend/tests/bug35634.phpt is failing currenlty

Reported by: judas_iscariote Owned by: moo
Priority: major Milestone:
Component: cacher Version: 1.2-dev
Keywords: Cc:
Application: PHP Version: 5.2.2-dev
Other Exts: SAPI: apache2handler
Probability: Blocked By:
Blocking:

Description

that's it Zend/tests/bug35634.phpt is failing (copied here for convenience)

<?php
if (defined("pass3")) {

  class ErrorClass {
  }

} else if (defined("pass2")) {

  class TestClass {
    function __construct() {
    }
    function TestClass() {
      $this->__construct();
    }
  }

} else {

  function errorHandler($errorNumber, $errorMessage, $fileName, $lineNumber) {
    define("pass3", 1);
    include(__FILE__);
    die("Error: $errorMessage ($fileName:$lineNumber)\n");
  }

  set_error_handler('errorHandler');
  define("pass2", 1);
  include(__FILE__);
}
?>

Expected:
Error-, Redefining already defined constructor for class TestClass?

actual result with only with xcache loaded:

Nothing, blank page. ( remember to set error_reporting=0 in php.ini or just run the php test suite)

Change History (2)

comment:1 Changed 7 years ago by moo

  • Status changed from new to assigned

comment:2 Changed 7 years ago by moo

  • Milestone 1.2.1 deleted
  • pending set to 0
  • Resolution set to wontfix
  • Status changed from assigned to closed

it is by design to be incompatible after XCache is enabled on E_STRICT problem. support for handling any error during compilation.

marked as wontfix until i figure a woarkarround

Note: See TracTickets for help on using tickets.