Opened 8 years ago

Closed 7 years ago

#59 closed defect (fixed)

Maximum execution time of 60 seconds exceeded with SquirrelMail 1.4.8, XCache-1.2.0, php 5.1.6

Reported by: shark Owned by: moo
Priority: major Milestone: 1.2.2
Component: cacher Version: 1.2-dev
Keywords: Cc:
Application: PHP Version: 5.1.x only
Other Exts: SAPI: FastCGI
Probability: Blocked By:
Blocking:

Description (last modified by judas_iscariote)

When I try read some of email il log i see this:

2006-12-21 21:35:08: (mod_fastcgi.c.2502) FastCGI-stderr: PHP Fatal error: Maximum execution time of 60 seconds exceeded in /var/www/public_html/webmail/src/read_body.php on line 97

i have this in my php.ini:

[xcache]
xcache.shm_scheme =        "mmap"
; to disable: xcache.size=0
; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
xcache.size  =                64M
xcache.count =                 1
xcache.slots =                8K
xcache.ttl   =                 0
xcache.gc_interval =           0
xcache.var_size  =            0M
xcache.var_count =             1
xcache.var_slots =            8K
xcache.var_ttl   =             0
xcache.var_maxttl   =          0
xcache.var_gc_interval =     300
xcache.test =                Off
xcache.readonly_protection = Off
; for *nix, xcache.mmap_path is a file path, not directory.
; Use something like "/tmp/xcache" if you want to turn on ReadonlyProtection
; 2 group of php won't share the same /tmp/xcache
; for win32, xcache.mmap_path=anonymous map name, not file path
xcache.mmap_path =    "/dev/zero"
xcache.coredump_directory =   ""
xcache.cacher =               On
xcache.stat   =               On
xcache.optimizer =           Off
[xcache.coverager]
; enable coverage data collecting for xcache.coveragedump_directory and xcache_coverager_start/stop/get/clean() functions (will hurt executing performance)
xcache.coverager =          Off
; requires xcache.coverager=On
xcache.coveragedump_directory = ""

max_execution_time = 60     ; Maximum execution time of each script, in seconds
max_input_time = 60     ; Maximum amount of time each script may spend parsing request data
memory_limit = 32M      ; Maximum amount of memory a script may consume (8MB)

Change History (20)

comment:1 Changed 8 years ago by judas_iscariote

  • Description modified (diff)
  • Milestone set to 1.2.1
  • Version changed from 1.0.1 to 1.2-dev

comment:2 Changed 8 years ago by judas_iscariote

Squirellmail works fine here..(it is part of the tested apps atm) are you sure it works fine when xcache is disabled ?

can you upgrade your php version ??

comment:3 Changed 8 years ago by judas_iscariote

  • Resolution set to worksforme
  • Status changed from new to closed

not reproducible with SquirrelMail? version 1.4.10 [CVS], lighttpd-1.4.13, PHP 5.2.1RC3-dev (cgi-fcgi) (built: Jan 13 2007 14:44:37) (DEBUG), adn current 1.2 svn branch, reopen if you can provide more info.

comment:4 Changed 8 years ago by netty

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can easily replicate it and i cant upgrade/downgrade PHP.
Condition identical to this happens if you have xcache enabled:
http://bugs.php.net/bug.php?id=35070

Just try the test script there and you can see you get:
one
one
one

Which is incorrect.

And yes it works fine if xcache is disabled.
Running Php-5.1.6(fcgi) (from CentOS plus repository)
OS - CentOS 4.4( running kernel 2.6.9-42.0.3.ELsmp)
webserver - lighttpd-1.4.13-1
Squirrelmail version 1.4.9a

I've finally disabled xcache :(

comment:5 Changed 8 years ago by judas_iscariote

  • Resolution set to worksforme
  • Status changed from reopened to closed

php test.php
one
two
three

what are you talking about ?

works for me, with xcache 1.2 svn branch, PHP 5.2. this is a problem on your system or you are using an outdated xcache version.

comment:6 Changed 8 years ago by netty

  • Resolution worksforme deleted
  • Status changed from closed to reopened

PHP5.2 isnt being offered on Redhat platforms as it needs PCRE upgrade.
It may not appear before Redhat enterprise linux 5.
This is why i'm forced to use 5.1.6.
I cant even use 5.0.4 as xcache doesnt supports it(my primary reason to use PHP 5.1.6).
Do you mean i need to wait for now or maintain PHP on my own because xcache wont support this version too?
Sorry i forgot to mention I'm using xcache 1.2.0-0.2

comment:7 Changed 7 years ago by moo

  • Summary changed from SquirrelMail 1.4.8, xcache xcache-1.2.0, php 5.1.6 to Maximum execution time of 60 seconds exceeded with SquirrelMail 1.4.8, XCache-1.2.0, php 5.1.6

comment:8 Changed 7 years ago by judas_iscariote

reproduced , only with 5.1.x. nor 5.2.x nor 4.4.x

this both standard test helps

Bug #25359 (array_multisort() does not work in a function if array is global or reference) [ext/standard/tests/array/bug25359.phpt]
Bug #35022 (Regression in the behavior of key/current functions) [ext/standard/tests/array/bug35022.phpt](same bug the reporter mentioned)

comment:9 Changed 7 years ago by moo

  • PHP Version set to 5.1.x only

comment:10 Changed 7 years ago by moo

canu pls check if [344] works for u?

comment:11 Changed 7 years ago by moo

don't try [344], it's unstable

comment:12 Changed 7 years ago by moo

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in [344] [345] [346]

comment:13 Changed 7 years ago by moo

merged to b1.2 in [378]

comment:14 Changed 7 years ago by moo

a build fix is in [379]

comment:15 Changed 7 years ago by XenoPhage

  • Resolution fixed deleted
  • Status changed from closed to reopened

I can reproduce this exact problem, CentOS 5.0, XCache 1.2.0, PHP 5.1.6

Is there a download link for the XCache version that fixes this issue?

comment:16 Changed 7 years ago by moo

  • Resolution set to fixed
  • Status changed from reopened to closed

please do not reopen bug for older version than the newer one which we fixed just because the new one isn't released yet.

if you need any help, just ask in the comment or in http://forum.lighttpd.net/forum/4/

see http://trac.lighttpd.net/xcache/wiki/GettingSource for "Checkout Source With SVN". i'm sorry that our auto snapshot cron job is unavailable untill i move it to another box.

comment:17 Changed 7 years ago by moo

  • pending set to 0
  • Resolution fixed deleted
  • SAPI set to FastCGI
  • Status changed from closed to reopened

XenoPhage? report in [106] that this bug should be reopened.

comment:18 Changed 7 years ago by moo

#106 i meant

comment:19 Changed 7 years ago by moo

  • Milestone changed from 1.2.1 to 1.2.2

comment:20 Changed 7 years ago by moo

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in [435] for trunk and [437] for b1.2

Note: See TracTickets for help on using tickets.