Opened 14 years ago

Closed 14 years ago

#52 closed defect (fixed)

Problem with adodb when use pdo_mysql driver

Reported by: safari Owned by: moo
Priority: major Milestone: 1.2
Component: cacher Version: 1.1-rc1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI:
Probability: Blocked By:




echo "<BR>before";
$conn =& NewADOConnection("pdo_mysql://user:pwd@localhost/dbname?persist");

When not use xCache, will see "before" and the dump of $conn value.
When use xCache, see "before" only; change connection type to mysql/mysqli, it worked again.
No error found in apache/php log.

I guess that xCache has problem when compiling/caching file or When the error happened, the file was compiled/cached, but was not.

This bug also happened with eaccelerator, wonder why? (use the same code/idea???); but worked fine with APC.

Change History (3)

comment:1 Changed 14 years ago by judas_iscariote

works perfectly , here.. try with a trunk snapshot.

comment:2 Changed 14 years ago by safari

confirmed. worked with trunk r272

comment:3 Changed 14 years ago by moo

  • Resolution set to fixed
  • Status changed from new to closed

thanks safari, closing as "fixed" instead of "invalid"

Note: See TracTickets for help on using tickets.