Opened 8 years ago

Closed 8 years ago

#46 closed defect (fixed)

xcache breaks Wordpress plugin WP-Cache2

Reported by: john@… Owned by: moo
Priority: major Milestone: 1.2
Component: cacher Version: 1.0.1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI:
Probability: Blocked By:
Blocking:

Description

When I turn on xcache.cacher I get blank pages from my Wordpress blogs running WP-Cache2 plugin.

I can cause blank pages without enabling xcache.cacher by commenting out the class_exists check in wp-cache-config.php but I can't prove these are connected in anyway.

This is with WP-Cache version 2.0.17 and xcache 1.0.1.

http://mnm.uib.es/gallir/wp-cache-2/

Change History (7)

comment:1 Changed 8 years ago by judas_iscariote

can u please tell us what the apache ( or your webserver) says when the blank page is shown ?

it segfaults ? it "cannot redeclare (function|class|whatever)" ???

comment:2 Changed 8 years ago by moo

try to enable error_reporting, either display it in browser by setting display_errors or log it to file by setting error_log, in php.ini

comment:3 Changed 8 years ago by moo

  • Milestone changed from 1.0.3 to 1.2

comment:4 Changed 8 years ago by john@…

I get no errors from php. I've tried both displaying and logging errors and I get nothing.

This is with PHP 5.1.2 btw. Xcache works with other php scripts on the same server, just not with WP-Cache.

It's running as a standalone fastcgi server with lighttpd connecting to it over a socket, but I doubt that makes a difference.

sorry for the delay, I've not had chance to test this until now.

comment:5 Changed 8 years ago by judas_iscariote

John, can u please try the current SVN trunk version and tell us if that works ?

I guess the problem is likely to be fixed there... ;)

comment:6 Changed 8 years ago by john@…

It's fixed in xcache-trunk-r262.tar.bz2

Massive speed boost now, thanks!

comment:7 Changed 8 years ago by moo

  • Resolution set to fixed
  • Status changed from new to closed

thanks for your response

Note: See TracTickets for help on using tickets.