Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#367 closed defect (fixed)

AUTOCHECK ERROR: ==== store zend_op_array ================= in 3.2.0

Reported by: trurl Owned by: moo
Priority: critical Milestone: undecided
Component: build Version: 3.2.0
Keywords: zend_op_array Cc:
Application: PHP Version: 5.6.20
Other Exts: SAPI: Others
Probability: Always Blocked By:
Blocking:

Description

Can't compile version 3.2.0 (https://xcache.lighttpd.net/pub/Releases/3.2.0/xcache-3.2.0.tar.gz) with php-5.6.20 (http://php.net/get/php-5.6.20.tar.xz/from/this/mirror)

Doing all as wiki:BuildingFromSource , but *make* failed with
AUTOCHECK ERROR: ==== store zend_op_array =================
AUTOCHECK ERROR: ==== restore zend_op_array =================
AUTOCHECK ERROR: ==== dprint zend_op_array =================
AUTOCHECK ERROR: ==== dasm zend_op_array =================

build based on official https://hub.docker.com/_/php/ 5.6.20-fpm-alpine

with svn://svn.lighttpd.net/xcache/trunk same error

Attachments (5)

xbuild.log (14.6 KB) - added by trurl 19 months ago.
build log (docker build -t trurlmcbyte/phpdir -f Dockerfile.xcache.test . &> xbuild.log)
Dockerfile.xcache.test (4.8 KB) - added by trurl 19 months ago.
Dockerfile
docker-php-ext-configure (434 bytes) - added by trurl 19 months ago.
docker-php-ext-enable (1.8 KB) - added by trurl 19 months ago.
docker-php-ext-install (1.3 KB) - added by trurl 19 months ago.

Download all attachments as: .zip

Change History (7)

Changed 19 months ago by trurl

build log (docker build -t trurlmcbyte/phpdir -f Dockerfile.xcache.test . &> xbuild.log)

Changed 19 months ago by trurl

Dockerfile

Changed 19 months ago by trurl

Changed 19 months ago by trurl

Changed 19 months ago by trurl

comment:1 follow-up: Changed 19 months ago by moo

make sure you have gnu awk installed. other awk might works but it seems yours doesn't

comment:2 in reply to: ↑ 1 Changed 19 months ago by trurl

  • Resolution set to fixed
  • Status changed from new to closed

Replying to moo:

make sure you have gnu awk installed. other awk might works but it seems yours doesn't

Big thanx!
Has added flex, bison and gawk. And it's solve problem.
Better to add this pre-requirements into wiki.

Last edited 19 months ago by trurl (previous) (diff)
Note: See TracTickets for help on using tickets.