Opened 6 months ago

Closed 6 months ago

#344 closed defect (invalid)

XCache is displaying var cache warning

Reported by: lalitkumar Owned by: moo
Priority: major Milestone: undecided
Component: cacher Version: 3.0.4
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

Hello!

First of all, thanks for this brilliant software. It seemed to have solved my long-standing problem of slow MediaWiki?. However, I am facing two problems:

1) Admin panel of XCache is very unstable. All the data keeps on going up and down unpredictably on refresh. Hit count, for example, keeps on going up and down. Also, Diagnosis tab is sometimes all green (meaning everything is good and OK) and then suddenly it begins to show errors.

2) I have set the following:

xcache.var_size = 100M (in php.ini)
$wgMainCacheType = CACHE_ACCEL; (in LocalSettings?.php of MediaWiki?)

But still I am getting the following Warning message on all the pages of my wiki (well, in fact, appearance of this message is also unpredictable -on some pages it appears and on some it doesn't)

Warning: xcache_get() [function.xcache-get]: XCache var cache was not initialized properly. Check php log for actual reason in /home/lalit76/public_html/kk/includes/objectcache/XCacheBagOStuff.php on line 38

I have tried to find solution through Google and everywhere it is said that the xcache.var_size should be set to something like 100M; which I have already done. I also have told MW to use xcache and it is also working because cache gets hits.

Still the tens of warning messages appear on a lot of pages.

I am attaching screenshots of Admin Cacher and Diagnosis tabs.

Please help!

Attachments (1)

xcache-2.JPG (164.4 KB) - added by lalitkumar 6 months ago.
Cacher tab

Download all attachments as: .zip

Change History (2)

Changed 6 months ago by lalitkumar

Cacher tab

comment:1 Changed 6 months ago by moo

  • Resolution set to invalid
  • Status changed from new to closed

Please ask question in google group
Check Summary page for Instance ID see if it change, if it does you have wrong sapi configuration (mostly wrong fcgi configuration)
See Faq page

Note: See TracTickets for help on using tickets.