Opened 7 months ago

Last modified 5 weeks ago

#340 infoneeded_new defect

XCache 3.1.0 causes nginx 502 bad gateway error

Reported by: lbebo Owned by: moo
Priority: major Milestone: undecided
Component: cacher Version: 3.1.0
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

Hi,

I installed a LNMP enviroment on my VPS and the PHP is 5.5.10 and nginx is 1.4.6. I tried to compile and install the XCache and I can see the information from php -v. When I tried to access any page using PHP, I got 502 error. From the log of nginx, I can see a lot of errors:

connect() to unix:/tmp/php-cgi.sock failed (2: No such file or directory) while connecting to upstream.

If i commented the extension = xcache.so, there will be no error at all. I tried almost of every method I can find in Google, but nothing helped.

Change History (2)

comment:1 Changed 7 months ago by moo

you have to check for php startup log to see what's going on

comment:2 Changed 5 weeks ago by moo

  • Status changed from new to infoneeded_new
Note: See TracTickets for help on using tickets.