Opened 6 years ago

Last modified 6 years ago

#332 accepted defect

XCache crashes

Reported by: shihabkhalil Owned by: moo
Priority: major Milestone: 3.3.0
Component: cacher Version: 3.1.0
Keywords: Cc:
Application: PHP Version: 5.2.17
Other Exts: Zend OPcache SAPI: FastCGI
Probability: Always Blocked By:



I have installed XCache on a Windows 2008 R2 64bit server 4 processors 2 cores each (total 8 cores) 16GB RAM

PHP is 5.2.17 Thread Safe running on IIS7.5 FastCGI.

The PHP/FastCGI receives a fatal crash. I tried to disable all extensions except xcache and same result.

Even the XCache diagnosis application provided causes the crash.

Attachments (3)

Temp1.rar (197.8 KB) - added by shihabkhalil 6 years ago.
Dump Trace 1
Temp2.rar (195.4 KB) - added by shihabkhalil 6 years ago.
Dump Trace 2
phpinfo().htm (57.4 KB) - added by shihabkhalil 6 years ago.

Download all attachments as: .zip

Change History (17)

Changed 6 years ago by shihabkhalil

Dump Trace 1

Changed 6 years ago by shihabkhalil

Dump Trace 2

comment:1 Changed 6 years ago by moo

  • Status changed from new to accepted

comment:2 Changed 6 years ago by moo

according to the dump file you provided, it's crash inside ZendOptimizer?. It's an indicate to compatibility problem on Zend Optimizer against XCache. Please provide PHP info output so I can know more versions about all extension you've loaded, especially Zend Optimizer

comment:3 Changed 6 years ago by moo

  • Milestone changed from undecided to 3.1.1

Changed 6 years ago by shihabkhalil

comment:4 Changed 6 years ago by shihabkhalil

Hi.. I have attached the phpinfo file.


comment:5 Changed 6 years ago by moo

This is again relative to Zend Optimizer. Do you have any Zend encoded files? if not, disable Zend Optimizer. Can you please disable it and see if it crash.

I'll try to reproduce it anyway when I have time

comment:6 Changed 6 years ago by Lx_Danny

I can confirm this.

[Tue Feb 18 13:51:06 2014] [notice] child pid 30382 exit signal Segmentation fault (11)

# php -v
PHP 5.2.17 (cli) (built: Dec 18 2013 16:48:28)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with XCache v3.1.0, Copyright (c) 2005-2013, by mOo
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies
    with XCache Cacher v3.1.0, Copyright (c) 2005-2013, by mOo

CentOS 5.10

It fails also with Lighttpd.

Edit: By disable zend optimizer it works fine.

Last edited 6 years ago by Lx_Danny (previous) (diff)

comment:7 Changed 6 years ago by Lx_Danny

Is it possible to fix this very fast and release 3.1.1 ?
Our controlpanel fails on this and users are complaining.

comment:8 Changed 6 years ago by Lx_Danny

Hi, Our Hosting controlpanel Kloxo ( Does have over 2000 installations. Each installation hosts a few to a few thousands websites. Each installation that uses XCache does have a big problem with showing the websites. Tho we advise to turn of Xcache for the time beeing and their websites and clients are happy again.

Please give some progress or feedback on this else we have to Publicy announce to our community to not to use XCache at all and we have to remove XCache abillities from our controlpanel software. Then we have to look for a better caching solution.

So please be kind to solve this as fast as possible and give at least some feedback.

Thank you.

comment:9 Changed 6 years ago by dkstiler

i use the hosting panel!!
I can confirm i have the same problem with lx_Danny when i try to activate XCache plugin my sites are all down!!

Please advice for an action !!

Last edited 6 years ago by dkstiler (previous) (diff)

comment:10 Changed 6 years ago by moo

please disable ionCube PHP Loader, Zend Extension Manager, Zend Optimizer and restart php

provide short test case to reproduce the bug

comment:11 Changed 6 years ago by Lx_Danny

Well reproduce it is very simpel.
Install: CentOS 5
Install: PHP 5.2.17
Install: ionCube PHP Loader v4.2.2
Install: Zend Optimizer v3.3.9
Install: XCache v3.1.0

Everything can be installed from:
For ioncube/zend: (32bit) (64bit)

Ofcourse it is doing nothing by default if installing all of this without Kloxo our Hosting controlpanel.

I can provide you a VPS with all of this installed so you can dig yourself into the case. Contact me for details about the VPS (contact@…).

And like i said, by disabling the other extensions, XCache works fine and does not crash the HTTPD server (apache or lighttpd). So that was a odd question to say disable the ioncube/zend extensions en restart php... well PHP can not be restarted :-) and this info was already written in this ticket.

I suggest you contact me so i can setup a VPS for you, provide you with login details and you can dig this all out in your own way.

Kind Regards,

comment:12 Changed 6 years ago by moo

Thanks. I'll give it a shot. zend_extension(s) that relative to Zend Engine will change behavior of php engine internally. although the changes may or may not affect PHP language behavior

mail sent but ...

Hi. This is the qmail-send program at
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

Sorry, no mailbox here by that name. (#5.1.1)
Subject: XCache bug #332
Content-Type: text/plain; charset=UTF-8

I'm the one behind XCache,

Thanks for your kindness to provide VPS for reproducing the bug.
please mail me all info needed to login the vps host.
ip/port/user/password (root needed)
how to restart php, where is xcache build, from source or from centos
gdb, valgrind, gcc, php-dev is needed
is "apt-get install appname" for more centos package?

comment:13 Changed 6 years ago by Lx_Danny

I received the email and send twice mail to you with login details.

comment:14 Changed 6 years ago by moo

  • Other Exts set to Zend OPcache
Note: See TracTickets for help on using tickets.