Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#328 closed defect (duplicate)

segfaults when using XCache 2.0.1 under heavy load

Reported by: boxdev Owned by: moo
Priority: critical Milestone: 3.0.4
Component: cacher Version: 2.0.1
Keywords: Cc:
Application: PHP Version: 5.4.13
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

Some of our machines have XCache 2.0.1 installed. In case this helps with troubleshooting XCache 3.0.x, here are some stack traces.

We would appreciate your feedback on what other data we can gather.

Version of XCache: php-xcache-2.0.1-5.4.13_box2.el6.x86_64
Version of PHP: php-5.4.13-1.el6.x86_64
Version of Apache: httpd-2.2.15-15.sl6.1.x86_64
OS: Scientific Linux 6
Output of 'uname -a': Linux pod4201-upload01.pod.box.net 2.6.32-220.23.1.el6.x86_64 #1 SMP Mon Jun 18 09:58:09 CDT 2012 x86_64 x86_64 x86_64 GNU/Linux
Frequency of occurrence: Normally very low. But intermittently, every web server request results in a segfault.
xcache.readonly_protection = On

Once a server gets into the state where all requests result in a segfault, we bounce httpd and requests can be processed normally again.

Attachments (1)

coredumps.20130909.txt (24.5 KB) - added by boxdev 12 months ago.

Download all attachments as: .zip

Change History (5)

Changed 12 months ago by boxdev

comment:1 Changed 11 months ago by moo

  • PHP Version set to 5.4.13
  • Status changed from new to accepted

do you have some box with 3.0.3 with xcache.readonly_protection = On? any core dumps there?

comment:2 Changed 11 months ago by boxdev

Hi. Although we noticed segfaults when using PHP 5.4.13 and XCache 2.0.1, we are still evaluating the newer version of XCache before deploying it outside our test environment. I am working on a project to set up a staging machine with XCache 3.0.3 in order to see what segfaults appear. I will provide some stack traces when they become available.

Thank you.

comment:3 Changed 11 months ago by moo

  • Resolution set to duplicate
  • Status changed from accepted to closed

2.0.1 is deprecated in favor of 3.0.x. closing this ticket as either duplicate of #324 or a "worksforme". thanks for your time filling in details

comment:4 Changed 11 months ago by moo

  • Milestone changed from undecided to 3.0.4
Note: See TracTickets for help on using tickets.