#290 closed defect (fixed)

Can't compile on FreeBSD 9

Reported by: maxilampert Owned by: moo
Priority: major Milestone: 3.0.1
Component: build Version: 3.0.0
Keywords: Cc:
Application: PHP Version: 5.4.7
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

after running phpize ./configure --enable-xcache --enable-xcache-constant 'make' throws this error.

/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache.c -o xcache.lo
mkdir .libs
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache.c  -fPIC -DPIC -o .libs/xcache.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/util/xc_stack.c -o util/xc_stack.lo
mkdir util/.libs
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/util/xc_stack.c  -fPIC -DPIC -o util/.libs/xc_stack.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/util/xc_trace.c -o util/xc_trace.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/util/xc_trace.c  -fPIC -DPIC -o util/.libs/xc_trace.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_allocator.c -o xcache/xc_allocator.lo
mkdir xcache/.libs
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_allocator.c  -fPIC -DPIC -o xcache/.libs/xc_allocator.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_allocator_bestfit.c -o xcache/xc_allocator_bestfit.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_allocator_bestfit.c  -fPIC -DPIC -o xcache/.libs/xc_allocator_bestfit.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_compatibility.c -o xcache/xc_compatibility.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_compatibility.c  -fPIC -DPIC -o xcache/.libs/xc_compatibility.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_const_string.c -o xcache/xc_const_string.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_const_string.c  -fPIC -DPIC -o xcache/.libs/xc_const_string.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_extension.c -o xcache/xc_extension.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_extension.c  -fPIC -DPIC -o xcache/.libs/xc_extension.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_ini.c -o xcache/xc_ini.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_ini.c  -fPIC -DPIC -o xcache/.libs/xc_ini.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_lock.c -o xcache/xc_lock.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_lock.c  -fPIC -DPIC -o xcache/.libs/xc_lock.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_opcode_spec.c -o xcache/xc_opcode_spec.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_opcode_spec.c  -fPIC -DPIC -o xcache/.libs/xc_opcode_spec.o
/bin/sh /root/xcache-build/libtool --mode=compile cc  -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/xcache-3.0.0/xcache/xc_processor.c -o xcache/xc_processor.lo
 cc -I. -I/root/xcache-3.0.0 -DPHP_ATOM_INC -I/root/xcache-build/include -I/root/xcache-build/main -I/root/xcache-3.0.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/xcache-3.0.0/xcache/xc_processor.c  -fPIC -DPIC -o xcache/.libs/xc_processor.o
/root/xcache-3.0.0/xcache/xc_processor.c:1:28: error: xc_processor.c.h: No such file or directory
*** Error code 1

Stop in /root/xcache-build.

Attachments (1)

Makefile (19.8 KB) - added by maxilampert 21 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 21 months ago by moo

  • Status changed from new to assigned

looks like missing dependency in Makefile. please try "make xc_processor.c.h" and then "make"

comment:2 Changed 21 months ago by moo

do "ls c_processor.c.h" in the build directory to see if it exists. attach Makefile here

comment:3 Changed 21 months ago by maxilampert

there is no c_processor.c.h, I'm using the unmodified Makefile from the tar.gz

comment:4 Changed 21 months ago by moo

sorry. i mean xc_processor.c.h, it should be generated on build

there is no Makefile from tar.gz, it is generated from configure which is generated by phpize from Makefile.*

Changed 21 months ago by maxilampert

comment:5 Changed 21 months ago by maxilampert

Forgot about that, tried with 'xc_processor.c.h' doesn't work. Attachted the Makefile

comment:6 Changed 21 months ago by moo

the Makefile looks good to me. maybe "multiple rule for single target" (see below) is not supported by your make, try gnu make

comment:7 Changed 21 months ago by moo

reproduced under your env. passed with "make ./xc_processor.c.h; make". looking for a fix

comment:8 Changed 21 months ago by maxilampert

Ok works but after coping the xcache.so to the php extension dir and restarting php-fpm I got the error /usr/local/lib/php/20100525/xcache.so doesn't appear to be a valid Zend extension

comment:9 Changed 21 months ago by moo

read XCache release note

comment:10 Changed 21 months ago by moo

  • Version set to 3.0.0

confirmed to be a PHP build system vs fbsd make bug agaconfirmed to be a PHP build system vs fbsd make bug again. workaround again in [1160]in. workaround again in [1160]

comment:11 Changed 21 months ago by moo

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.