#284 closed defect (fixed)

Cache not updated after renaming or moving directory

Reported by: mcoelho80 Owned by: moo
Priority: major Milestone: 2.0.1
Component: cacher Version:
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

This is what happens when I move a Joomla! instalation from /joomla/ to /joomla2/:


Warning: require_once(/home/t/teste/www/joomla/includes/defines.php): failed to open stream: No such file or directory in /home/t/teste/www/joomla/index.php on line 18

Fatal error: require_once(): Failed opening required '/home/t/teste/www/joomla/includes/defines.php' (include_path='.:/usr/local/lib/php') in /home/t/teste/www/joomla/index.php on line 18


XCache doesn't invalidate the cache because it doesn't check if the path was changed.

Other opcode cachers, like eAccelerator and APC don't cause this problem.

Change History (2)

comment:1 Changed 22 months ago by moo

  • Milestone changed from undecided to 2.0.1

confirmed. this is caused by an advanced feature from 2.0. maybe too late to be fixed in 2.0.1. i'll see if the fix is small and simple enough

comment:2 Changed 22 months ago by moo

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [964] (scheduled for 2.0.1). set "xcache.experimental = on" to eanble this fix for now

Note: See TracTickets for help on using tickets.