Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#275 closed defect (fixed)

compile error under osx 10.7.3 (Lion)

Reported by: lifeofguenter Owned by: moo
Priority: major Milestone: 2.0.0
Component: build Version: 1.3.2
Keywords: osx 10.7.3, osx lion, compile Cc:
Application: PHP Version: 5.3.8
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

I am unable to compile xcache under mac osx 10.7.3 (mbp early 2011 / i5 @2.3Ghz)

# uname -a
Darwin serenity 11.3.0 Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64 x86_64

# gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)

# php --version
PHP 5.3.8 with Suhosin-Patch (cli) (built: Nov 15 2011 15:33:15)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

with Xdebug v2.1.2, Copyright (c) 2002-2011, by Derick Rethans

This is the default PHP + Apache2 installation that comes with osx. Tried compiling xcache 1.3.2 and xcache-trunk:

# phpize
# ./configure --enable-xcache
# make

# make

/usr/bin/m4 -B 102400 -D srcdir='`'"/usr/src/xcache-trunk'" -D builddir='`'".'"  /usr/src/xcache-trunk/processor/main.m4 > ./processor.out.tmp
AUTOCHECK INFO: runtime autocheck Disabled (optimized build)
AUTOCHECK INFO: zend_compiled_variable: processor looks good
AUTOCHECK INFO: zend_try_catch_element: processor looks good
AUTOCHECK INFO: zend_brk_cont_element: processor looks good
AUTOCHECK INFO: HashTable: processor looks good
AUTOCHECK INFO: zval: processor looks good
AUTOCHECK INFO: zend_arg_info: processor looks good
AUTOCHECK INFO: zend_constant: processor looks good
AUTOCHECK INFO: zend_property_info: processor looks good
AUTOCHECK WARN: zend_trait_method_reference: missing structinfo, dont panic
AUTOCHECK WARN: zend_trait_alias: missing structinfo, dont panic
AUTOCHECK WARN: zend_trait_precedence: missing structinfo, dont panic
AUTOCHECK INFO: zend_class_entry: processor looks good
AUTOCHECK ERROR: ==== calc znode =================
AUTOCHECK expected: "__asm","__asm","__asm","__asm","mkdir","mkfifo","__asm","mknod","umask","_filesec","filesec_t","chflags","chmodx_np","fchflags","fchmodx_np","__asm","__asm","mkdirx_np","mkfifox_np","__asm","mlockall","munlockall","mlock","__asm","__asm","__asm","munlock","__asm","shm_open","shm_unlink","posix_madvise","madvise","mincore","minherit","closelog","openlog","setlogmask","zend_op_array","zend_op","op_type","u"
AUTOCHECK missing : "__asm" "__asm" "__asm" "__asm" "mkdir" "mkfifo" "__asm" "mknod" "umask" "_filesec" "filesec_t" "chflags" "chmodx_np" "fchflags" "fchmodx_np" "__asm" "__asm" "mkdirx_np" "mkfifox_np" "__asm" "mlockall" "munlockall" "mlock" "__asm" "__asm" "__asm" "munlock" "__asm" "shm_open" "shm_unlink" "posix_madvise" "madvise" "mincore" "minherit" "closelog" "openlog" "setlogmask" "zend_op_array" "zend_op" 
AUTOCHECK WARN: zend_op: missing structinfo, dont panic
AUTOCHECK WARN: zend_literal: missing structinfo, dont panic
AUTOCHECK WARN: zend_op_array: missing structinfo, dont panic
AUTOCHECK INFO: xc_constinfo_t: processor looks good
AUTOCHECK INFO: xc_op_array_info_detail_t: processor looks good
AUTOCHECK INFO: xc_op_array_info_t: processor looks good
AUTOCHECK INFO: xc_funcinfo_t: processor looks good
AUTOCHECK INFO: xc_classinfo_t: processor looks good
AUTOCHECK INFO: xc_autoglobal_t: processor looks good
AUTOCHECK INFO: xc_compilererror_t: processor looks good
AUTOCHECK INFO: xc_entry_data_php_t: processor looks good
AUTOCHECK INFO: xc_entry_t: processor looks good
AUTOCHECK INFO: xc_entry_php_t: processor looks good
AUTOCHECK INFO: xc_entry_var_t: processor looks good
AUTOCHECK ERROR: ==== store znode =================
AUTOCHECK ERROR: ==== restore znode =================
AUTOCHECK ERROR: ==== dprint znode =================
AUTOCHECK ERROR: ==== dasm znode =================
AUTOCHECK ERROR: ==== asm znode =================
make: *** [processor.out] Error 1

Attachments (2)

config.log (20.4 KB) - added by lifeofguenter 3 years ago.
structinfo.m4 (88.8 KB) - added by lifeofguenter 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by lifeofguenter

comment:1 Changed 3 years ago by moo

  • Status changed from new to assigned

please attach includes.i, structinfo.m4

Changed 3 years ago by lifeofguenter

comment:2 Changed 3 years ago by lifeofguenter

I could not attach the includes.i in here due to the filesize restriction. Please download/view it from following url: http://static.lifeofguenter.de/includes.i

thank you for checking.

comment:3 Changed 3 years ago by moo

  • Milestone changed from undecided to 2.0.0
  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in [891] for 2.0.0

comment:4 Changed 3 years ago by lifeofguenter

Thanks man for the fix. I was able to make && make install -> works now perfect!

Note: See TracTickets for help on using tickets.