Opened 3 years ago

Closed 2 years ago

#272 closed defect (invalid)

xcache crashes site - need help

Reported by: starams5 Owned by: moo
Priority: major Milestone: misc
Component: cacher Version: 1.3.2
Keywords: Cc:
Application: PHP Version: 5.3.8
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

Hi,

Could someone please help me with the problem I have with xcache, maybe I'm doing something wrong. I install xcache and it seem to work fine for a few hours, then it takes the entire site out, and I have to revert to the backup. xcache is much faster than the current optimizer (APC), but I can't seem to get it stable. Please see specs below, If I miss anything, just ask and I will provide it. Thanks.

XCache-1.3.2-php-5.3.6-Win32-VC9-x86 (default xcache.ini settings)

XAMPP 1.7.7:
Apache 2.2.21
MySQL 5.5.16
PHP 5.3.8

(APC Commented)

Windows Server 2008R2
16Gb Memory (Kingston)
x2 Intel Xeon E5620 Processors (12Mb cache)

Site Script: Socialengine 4.2.0

GZip Compression

Change History (14)

comment:1 Changed 3 years ago by starams5

  • pending changed from 0 to 1

comment:2 follow-up: Changed 3 years ago by moo

  • Milestone changed from 1.3.3 to 2.0.0
  • Status changed from new to assigned

this will be improved in 2.0.0

comment:3 in reply to: ↑ 2 Changed 3 years ago by starams5

Replying to moo:

this will be improved in 2.0.0

Thanks for replying. I tried beta 2.0, but couldn't get past the 2nd username/password prompt even though I generated an md5 pass and set username/password in php.ini as instructed. The option to disable "xcache.admin.enable_auth = On" is missing in the beta. Again, thanks fro your help.

comment:4 follow-up: Changed 3 years ago by moo

  • Milestone changed from 2.0.0 to misc

comment:5 in reply to: ↑ 4 Changed 3 years ago by starams5

Replying to moo:

thanks. how do you set "xcache.admin.enable_auth = On" to "xcache.admin.enable_auth = Off" using 2.0.0 rc1. it's the only way i can get it to work, thanks.

comment:6 follow-up: Changed 3 years ago by moo

please disable http auth for xcache-admin/* in your webserver

comment:7 in reply to: ↑ 6 Changed 3 years ago by starams5

Replying to moo:

please disable http auth for xcache-admin/* in your webserver

Thanks again, and for your patients. Could you please be more specific. I can handle the task with direction, but I'm no pro. As stated previously, I'm using XAMPP 1.7.7, a Windows box, and Apache 2.2.21 is the web server. I want to get XCache working, it's much faster. Thanks.

comment:8 Changed 3 years ago by starams5

Does any one here know how to get xcache working on a windows box/xampp? explanation please, one liners don't help. thanks.

comment:9 Changed 3 years ago by starams5

does anyone here know how to get past this (Windows/XAMPP)?


XCache Authentication Failed

You're not authorized to access this page due to wrong username and/or password you typed.
The following check points is suggested:

Be aware that Username' and Password' is case sense. Check capslock status led on your keyboard, and punch left/right Shift keys once for each
Make sure the md5 password is generated correctly. You may use mkpassword.php
Reload browser cache by pressing F5 and/or Ctrl+F5, or simply clear browser cache after you've updated username/password in php ini.

Check XCache wiki page for more information.

comment:10 Changed 3 years ago by starams5

when i try to clear the cache i get the following below, even though the username and pass is set... it keeps popping up (v2.0rc1):

Authentication Required

A username and password are being requested by http://localhost. The site says: "XCache Administration"

comment:11 Changed 3 years ago by starams5

you can close this ticket since no one here knows what their doing (Windows). Think we'll stick with APC, at least it's stable and don't take our site out. XCache has horrible support and documentation, too many bugs. thanks for nothing.

comment:12 Changed 3 years ago by moo

this is bogus statement, XCache tried to enforce security, yet no one know why authn fails here. is it because there's authn is enabled on apache2 side, or apache2 does not pass auth correctly to php when handling post in some case. we haven't yet to reproduce this issue. not everyone is capable to help XCache devel track this issue down, nor is the devel 24h available

comment:13 Changed 3 years ago by moo

and btw, in admin/config.php.example reside an example for how to by passing the auth by providing username/password in config.php

comment:14 Changed 2 years ago by moo

  • Resolution set to invalid
  • Status changed from assigned to closed

This is a PHP not XCache problem
see https://bugs.php.net/bug.php?id=62432

Note: See TracTickets for help on using tickets.