Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#260 closed defect (invalid)

The Zend Engine API version 220090626 which is installed, is newer.

Reported by: danliker Owned by: moo
Priority: critical Milestone:
Component: cacher Version: 1.3.1
Keywords: Cc:
Application: PHP Version: 5.3.6
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

i use CentOS release 5.5 (Final)

php -v
XCache requires Zend Engine API version 220060519.
The Zend Engine API version 220090626 which is installed, is newer.
Contact mOo at http://xcache.lighttpd.net for a later version of XCache.

PHP 5.3.6 (cli) (built: Mar 23 2011 17:24:24)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

with the ionCube PHP Loader v4.0.5, Copyright (c) 2002-2011, by ionCube Ltd.

and i get this in the apache error log:

[Thu Apr 07 13:33:44 2011] [notice] caught SIGTERM, shutting down
XCache requires Zend Engine API version 220060519.
The Zend Engine API version 220090626 which is installed, is newer.
Contact mOo at http://xcache.lighttpd.net for a later version of XCache.

is there a new version comming ?
xcache is 1.3.1

Change History (5)

comment:1 Changed 4 years ago by moo

  • Resolution set to invalid
  • Status changed from new to closed

this is not a XCache version problem, it's a build issue. XCache has to be rebuilt against the new PHP Engine. it's up to your CentOS release, please contact them

comment:2 Changed 4 years ago by danliker

comment:3 Changed 4 years ago by moo

then you might have used the wrong phpize and php-config, try not to mix different version of php5-dev package against php5-cgi package

comment:4 Changed 4 years ago by moo

Faq

comment:5 Changed 4 years ago by danliker

ok, sorry i linked the wrong xchache.so in the php.ini.....

Note: See TracTickets for help on using tickets.