Opened 5 years ago

Closed 2 years ago

#245 closed defect (duplicate)

PHP with xcache crash, after restore object variable

Reported by: NT Man Owned by: moo
Priority: major Milestone: 1.3.2
Component: cacher Version: 1.3.0
Keywords: Cc:
Application: PHP Version: 5.3.2
Other Exts: SAPI: FastCGI
Probability: Always Blocked By:
Blocking:

Description (last modified by moo)

My example demonstrate how easy make crash PHP with xcache.

<?php
class myclass {
	function __construct() {
	}
}

if(xcache_isset('my_obj')) {
	$my_object = xcache_get('my_obj');
	var_dump($my_object);
} else {
	$my_object = new myclass();
	xcache_set('my_obj', $my_object);
	var_dump($my_object);
}

?>

Change History (3)

comment:1 Changed 4 years ago by moo

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed

object is not supported in xcache_set/get, use serialize/unserialize instead

comment:2 Changed 2 years ago by moo

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:3 Changed 2 years ago by moo

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #37

Note: See TracTickets for help on using tickets.