Opened 6 years ago

Closed 4 years ago

#216 closed defect (invalid)

Drupal 7 HEAD segfaults xcache

Reported by: chx1975@… Owned by: moo
Priority: major Milestone: 1.3.2
Component: cacher Version: 1.2.1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description (last modified by moo)

Ubuntu Hardy:

0x00007f6d3680b060 in strlen () from /lib/libc.so.6
(gdb) bt
#0  0x00007f6d3680b060 in strlen () from /lib/libc.so.6
#1  0x00007f6d30fc8102 in lex_scan () from /usr/lib/apache2/modules/libphp5.so
#2  0x00007f6d30f8a2d6 in zif_token_get_all () from /usr/lib/apache2/modules/libphp5.so
#3  0x00007f6d31015f72 in ?? () from /usr/lib/apache2/modules/libphp5.so
#4  0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#5  0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#6  0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#7  0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#8  0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#9  0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#10 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#11 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#12 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#13 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#14 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#15 0x00007f6d30fdc775 in zend_call_function () from /usr/lib/apache2/modules/libphp5.so
#16 0x00007f6d30fdd7c6 in call_user_function_ex () from /usr/lib/apache2/modules/libphp5.so
#17 0x00007f6d30f2d627 in zif_call_user_func_array () from /usr/lib/apache2/modules/libphp5.so
#18 0x00007f6d31015f72 in ?? () from /usr/lib/apache2/modules/libphp5.so
#19 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#20 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#21 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#22 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#23 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#24 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#25 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#26 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#27 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#28 0x00007f6d31015a04 in ?? () from /usr/lib/apache2/modules/libphp5.so
#29 0x00007f6d31006ea3 in execute () from /usr/lib/apache2/modules/libphp5.so
#30 0x00007f6d30fe7743 in zend_execute_scripts () from /usr/lib/apache2/modules/libphp5.so
#31 0x00007f6d30fa39ca in php_execute_script () from /usr/lib/apache2/modules/libphp5.so
#32 0x00007f6d31067cc2 in ?? () from /usr/lib/apache2/modules/libphp5.so
#33 0x0000000000437d6a in ap_run_handler ()
#34 0x000000000043b18c in ap_invoke_handler ()
#35 0x000000000044786e in ap_process_request ()
#36 0x0000000000444c68 in ?? ()
---Type <return> to continue, or q <return> to quit---
#37 0x000000000043eec2 in ap_run_process_connection ()
#38 0x000000000044b665 in ?? ()
#39 0x000000000044b893 in ?? ()
#40 0x000000000044c469 in ap_mpm_run ()
#41 0x0000000000425a44 in main ()

Change History (3)

comment:1 Changed 6 years ago by chx

By checking the commits of Drupal 7, I found that this is caused by a patch which heavily uses FUNCTION and yes D7 uses token_get_all. http://xcache.lighttpd.net/ticket/55 seems related but then again, I have xcache.readonly_protection = Off . I tried to write a reproduce script but so far no success. Also, while it does segfault all the time while trying to install Drupal 7, it's not always the same file being tokenized that causes it to segfault, at least that's what I see in the mysql logfile.

comment:2 Changed 6 years ago by moo

  • Description modified (diff)

comment:3 Changed 4 years ago by moo

  • Resolution set to invalid
  • Status changed from new to closed

bug was fixed in newer version (1.2.2 and later). upgrade and reproduce it before reopening this bug

Note: See TracTickets for help on using tickets.