Opened 6 years ago

Closed 6 years ago

#212 closed defect (invalid)

XCache Is Not Loading - No Errors

Reported by: kaisellgren@… Owned by: moo
Priority: major Milestone: 1.3.0
Component: cacher Version: 1.2.2
Keywords: Cc:
Application: PHP Version: 5.2.5
Other Exts: SAPI: apache2handler
Probability: Always Blocked By:
Blocking:

Description

Hi,

I have been trying to load XCache extension without success. I have enabled startup errors on PHP.ini, but I do not get any errors. I have tried:
extension=php_xcache.dll
and:
zend_extension_ts="C:\Portable Programs\PHP\ext\php_xcache.dll"
and both do not do anything. I tried phpinfo() and it did not show XCache, I also tried some XCache functions and they were undefined of course...
I am editing the right PHP.ini, because there is no else ini files and when I commented APC and eAccelerator to make sure they won't interfere, then the changes happened = they were gone, but XCache still did not work.

Any ideas? I'm using PHP 5.2.5 and the latest Win32 binaries from your site as well the one DLL that comes with the PHP release.

Change History (1)

comment:1 Changed 6 years ago by moo

  • Resolution set to invalid
  • Status changed from new to closed

i'm not sure what happened. make sure php_xcache.dll is readable by SYSTEM account (under which account your php ran). make sure zend_extension_ts=\path\to\xcache.so is the first of all zend_extension_ts

http://forum.lighttpd.net/forum/4 is the right place for questions. you may get more help there

Note: See TracTickets for help on using tickets.