Opened 6 years ago

Closed 6 years ago

#200 closed defect (invalid)

Compatability issue with ZendOptimizer

Reported by: ShyaM Owned by: moo
Priority: major Milestone: 1.3.0
Component: cacher Version: 1.2.2
Keywords: zend Cc: sparxend@…
Application: PHP Version: 5.2.5
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

Hi,

When we install xcache in a server which already includes ZendOpt?. & Ioncube it produces the following error,
================
PHP Fatal error: [Zend Optimizer] Zend Optimizer 3.3.3 is incompatible with XCache 1.2.2 in Unknown on line 0
================

On further checking, it seems that xcache works either with ZendOpt? or Ioncube , but not with both. Also the above error produced when I installed ioncube. So there is still compatibility issue with xcache + zendopt + ioncube

Change History (1)

comment:1 Changed 6 years ago by judas_iscariote

  • Resolution set to invalid
  • Status changed from new to closed

PHP Fatal error: [Zend Optimizer] Zend Optimizer 3.3.3 is incompatible with XCache 1.2.2 in Unknown on line 0 ================

You have to blame Zend, they blacklist our stuff and many other opensource extensions for commercial reasons.

workaround: load Xcache before Zend.

Note: See TracTickets for help on using tickets.