Opened 6 years ago

Closed 5 years ago

Last modified 2 years ago

#197 closed defect (fixed)

xcache cache 2 different site with a strange merge (?!?)

Reported by: gmorandippp@… Owned by: moo
Priority: critical Milestone: 2.0.0
Component: cacher Version: 2.0.0
Keywords: Cc:
Application: PHP Version: 5.2.6
Other Exts: SAPI: FastCGI
Probability: Blocked By:
Blocking:

Description

Hello, i am here to report a strange bug of the current svn version of xcache.

first of all, setup config
1) lighttpd 1.5 (updated now)
2) php 5.2.6
3) xcache svn

sites
there are many different site, that are hosted via
$HTTPhost? == "angelmule.com"
$HTTPhost? == "forum-it.alaunt.com"
and so on

on angelmule.com and forum-it.alaunt.com, is installed a forum, mybboard.
obviusly they are different in content, but not in version.
forum file are, obviusly, in 2 different folders on my server.

so, things are going pretty well without xcache, i use php with spawn-fcgi, 8 process, all variable are correctly exported
export PHP_FCGI_MAX_REQUESTS
export PHP_FCGI_CHILDREN

and now, the wired stuff...

i turn on xcache, admin panel correctly worked, and site are up and reachable.
when i go to angelmule.com, i see mybboard with some part of code taken by forum-it.alaunt.com, and viceversa.

example: the title on the page on forum-it.alaunt.com is angelmule, and the title on the page of www.angelmule.com is alaunt forum :D
also, the content sometimes are switched, on alaunt -> angelmule and viceversa.

unfortunatly i can't reproduce it, or, better say, i cannot leave it in this situation for much time to allow you to see this problem.

Tell me if i can assist you with more informations

Change History (2)

comment:1 Changed 5 years ago by moo

  • Resolution set to fixed
  • Status changed from new to closed

I've addressed it in r662 finally :)

comment:2 Changed 2 years ago by moo

  • Milestone changed from 2.2.0 to 2.0.0
Note: See TracTickets for help on using tickets.