Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#171 closed defect (invalid)

Typo3 fails when Xcache is enabled

Reported by: steltek@… Owned by: moo
Priority: major Milestone: 1.3.0
Component: cacher Version: 1.2.1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

Using a Debian testing/lenny System my Typo3 installation (4.1.6) fails with:

Fatal error: Cannot redeclare class tx_lib_object in /var/www/site/typo3conf/ext/lib/class.tx_lib_object.php(606) : eval()'d code on line 1

when xcache is enabled. Disabling xcache makes this problem go away.

libapache2-php5: 5.2.3-1+lenny1 and 5.2.5-3 (both fail)
apache2-mpm-prefork: 2.2.8-3

xcache config:


[xcache]

xcache.shm_scheme = "mmap"

xcache.size = 16M

xcache.count = 1

xcache.slots = 8K

xcache.ttl = 0

xcache.gc_interval = 0

xcache.var_size = 4M

xcache.var_count = 1

xcache.var_slots = 8K

xcache.var_ttl = 0

xcache.var_maxttl = 0

xcache.var_gc_interval = 300

xcache.test = Off

xcache.readonly_protection = Off

xcache.mmap_path = "/dev/zero"

xcache.coredump_directory = ""

xcache.cacher = On

xcache.stat = On

xcache.optimizer = Off

[xcache.coverager]

xcache.coverager = Off

xcache.coveragedump_directory = ""

Change History (3)

comment:1 Changed 6 years ago by Steltek

Hello,

I just tested this again (lots of changes to the server in the meantime, Apache & PHP updates, Typo3 Updates, ...) and the problem is gone.

My current versions:

PHP: 5.2.6.dfsg.1-1+lenny2
Apache2: 2.2.11-2
Typo3: 4.2.4

comment:2 Changed 6 years ago by Steltek

Argh... OK, I spoke too soon. xcache just hadn't loaded. Problem persists.

comment:3 Changed 6 years ago by moo

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.