Opened 7 years ago

Closed 6 years ago

Last modified 16 months ago

#170 closed defect (duplicate)

xcache loads cached PHP files when directory name is changed

Reported by: Dark Light Owned by: moo
Priority: major Milestone: 2.0.1
Component: cacher Version: 1.2.2
Keywords: Cc:
Application: PHP Version: 5.2.3
Other Exts: SAPI: apache2handler
Probability: Always Blocked By:
Blocking:

Description

xcache loads cached PHP files when directory name is changed

xcache will load a pre-compiled PHP file if the directory name is changed. For example:

+ Create folder1
+ Create file1.php
++ Inside file1 type:

<?php echo dirname(FILE); ?>

+ Save file1.php
+ Browse to http://dom.ext/folder1/file1.php
+ Copy contents to text editor

+ Rename folder1 to folder2. Keep file1.php name intact.
+ Browse to http://dom.ext/folder2/file1.php
+ Copy contents to text editor

+ You will notice the contents are the same and xcache is using the older version of the PHP script even though clearly the directory path has changed.

-- Note: Might not be an xcache bug, but it's annoying and replicable on other systems all the same. Happens with APC (Alternative PHP Cache) too.

Thank you,
Best Regards,

Change History (4)

comment:1 Changed 7 years ago by Dark Light

Note: Ticket system altered PHP code. It should be:

<?php echo dirname(__FILE__); ?>

comment:2 Changed 7 years ago by Dark Light

Just noticed already reported here:

http://xcache.lighttpd.net/ticket/117

Sorry for the inconvenience!

comment:3 Changed 6 years ago by moo

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #117

comment:4 Changed 16 months ago by moo

  • Milestone set to 2.0.1
Note: See TracTickets for help on using tickets.