Opened 7 years ago

Closed 5 years ago

#161 closed defect (fixed)

xcache keeps on crashing, core attached

Reported by: ch@… Owned by: moo
Priority: major Milestone: 1.3.0
Component: cacher Version: 1.2.2
Keywords: Cc:
Application: PHP Version: 5.2.5
Other Exts: SAPI: apache2handler
Probability: Sometimes Blocked By:
Blocking:

Description (last modified by moo)

Hello

xcache keeps on crashin. I have three core files saved with an identical backtrace:

Core was generated by `/usr/sbin/apache2 -k start'.
Program terminated with signal 11, Segmentation fault.

(gdb) bt
#0  0x00002b215f95f887 in xcache_fcall_end_handler () from /usr/lib/php5/20060613/xcache.so
#1  0x00002b215aef5db2 in get_zend_version () from /usr/lib/apache2/modules/libphp5.so
#2  0x00002b215af00cd5 in zend_hash_apply () from /usr/lib/apache2/modules/libphp5.so
#3  0x00002b215aef6247 in zend_post_deactivate_modules () from /usr/lib/apache2/modules/libphp5.so
#4  0x00002b215aeb473a in php_request_shutdown () from /usr/lib/apache2/modules/libphp5.so
#5  0x00002b215af75943 in php_ap2_register_hook () from /usr/lib/apache2/modules/libphp5.so
#6  0x0000000000432cf9 in ap_run_handler ()
#7  0x0000000000435e72 in ap_invoke_handler ()
#8  0x0000000000441fe8 in ap_process_request ()
#9  0x000000000043f4cc in ap_register_input_filter ()
#10 0x0000000000439851 in ap_run_process_connection ()
#11 0x0000000000445961 in ap_graceful_stop_signalled ()
#12 0x0000000000445bd4 in ap_graceful_stop_signalled ()
#13 0x0000000000445c76 in ap_graceful_stop_signalled ()
#14 0x00000000004468cd in ap_mpm_run ()
#15 0x0000000000420e70 in main ()

I'm running xcache-1.2.2 with apache 2.2.3-4+etch3 + php5-5.2.5 on a Debian 4.0 'etch' system with the following config:

web8:/var/cache/apache2# php -i|egrep '(jit|xcac)'

/etc/php5/cli/conf.d/xcache.ini,
auto_globals_jit => Off => Off
xcache.admin.enable_auth => On => On
xcache.cacher => On => On
xcache.coredump_directory => no value => no value
xcache.count => 8 => 8
xcache.coveragedump_directory => no value => no value
xcache.coverager => Off => Off
xcache.gc_interval => 0 => 0
xcache.mmap_path => /var/cache/apache2/php_xcache => /var/cache/apache2/php_xcache
xcache.optimizer => Off => Off
xcache.readonly_protection => 1 => 1
xcache.shm_scheme => mmap => mmap
xcache.size => 128M => 128M
xcache.slots => 16K => 16K
xcache.stat => On => On
xcache.test => no value => no value
xcache.ttl => 0 => 0
xcache.var_count => 2 => 2
xcache.var_gc_interval => 300 => 300
xcache.var_maxttl => 0 => 0
xcache.var_size => 32M => 32M
xcache.var_slots => 8K => 8K
xcache.var_ttl => 0 => 0

It's gone now and I saw a warning that I set xcache.mmap_path to a directory. Maybe that was
the resason but still it definetly should not segfault!

As I had segfaults under Load for a couple of days now :(

bye,

-christian-

Change History (4)

comment:1 Changed 7 years ago by moo

  • Description modified (diff)
  • SAPI changed from Irrelevant to apache2handler
  • Status changed from new to assigned

mpm worker? looks like it happens on graceful restart only? do you have a cron job that do graceful restart regularly? if you build xcache with CFLAGS=-g, the backtrace would be more meanful
CFLAGS='-g -O1' ./configure && make clean && make && sudo make install

comment:2 Changed 7 years ago by moo

  • pending changed from 0 to 1

can you pls downgrade to PHP 5.2.4? there's a known issue in PHP 5.2.5

comment:4 Changed 5 years ago by moo

  • Milestone changed from 1.3.1 to 1.3.0
  • Resolution set to fixed
  • Status changed from assigned to closed

i assume it caused by a broken PHP 5.2.5 which issue memory corrupt

Note: See TracTickets for help on using tickets.