Opened 7 years ago

Closed 7 years ago

#158 closed defect (invalid)

Fatal error: Cannot redeclare function() with xcache 1.2.2

Reported by: ctribe Owned by: moo
Priority: major Milestone: 1.3.0
Component: cacher Version: 1.2.2
Keywords: Cc:
Application: PHP Version: 5.2.0-8
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

I've just installed Xcache to optimize vbulletin board but it's causing me some problems with website code.

Fatal error: Cannot redeclare manipulatetextforie() in /home/blabla/public_html/psp/functions.php on line 14

http://psp.console-tribe.com/archivio-news.php

http://ps3.console-tribe.com/archivio-news.php

I'm using te latest 1.2.2 xcache

Change History (3)

comment:1 Changed 7 years ago by moo

  • Probability set to Always
  • Version changed from 1.2.1 to 1.2.2

can u try to make a short reproduce sample code? or let me ssh on the server? msn/gtalk: phpxcache@…

comment:2 Changed 7 years ago by moo

  • Status changed from new to assigned

comment:3 Changed 7 years ago by moo

  • Resolution set to invalid
  • Status changed from assigned to closed

it's because there's 2 require("functions.php"); and i can't make it work even with XCache disabled. not a bug if you can make sure to it only happen after and not before XCache enabled and no other settings or source code is changed

Note: See TracTickets for help on using tickets.