Opened 7 years ago

Closed 18 months ago

#147 closed defect (fixed)

solaris, apache2.0 worker mpm: xc_fcntl_lock failed errno:13x

Reported by: crozierm@… Owned by: moo
Priority: major Milestone: 3.0.2
Component: cacher Version: 1.2.1
Keywords: xc_fcntl_lock failed solaris Cc:
Application: PHP Version: 5.2.4
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

(see configuration details at the end)

I was testing an XCache installation by request URL's from 6 concurrent clients. I noticed these messages in the apache error log:

xc_fcntl_lock failed errno:13

There were dozes of this message, with no endlines. When I changed xcache.count=1 to 2, I could not reproduce the error message.

Dual PIII

Solaris 9

Apache 2.0.59 w/ Worker MPM

PHP 5.2.4

XCache 1.2.1:

zend_extension_ts = /opt/php/lib/php/extensions/no-debug-zts-20060613/xcache.so

xcache.shm_scheme = "mmap"

xcache.shm_scheme = "mmap"

xcache.size = 64M

xcache.count = 2

xcache.slots = 8K

xcache.ttl = 0

xcache.gc_interval = 300

xcache.var_size = 64M

xcache.var_count = 1

xcache.var_slots = 8K

xcache.var_ttl = 0

xcache.var_maxttl = 0

xcache.var_gc_interval = 300

xcache.test = Off

xcache.readonly_protection = Off

xcache.mmap_path = "/opt/apache/logs/xcache.mem"

xcache.coredump_directory = "/var/tmp"

xcache.cacher = On

xcache.stat = On

xcache.optimizer = Off

xcache.coverager = Off

xcache.coveragedump_directory = ""

Change History (3)

comment:1 Changed 5 years ago by InventOR

freebsd 8.0 x64 with jails - similar problem.
apache2, php 5.2.4/5.3.1, XCache latest.

comment:2 Changed 2 years ago by moo

  • Milestone set to 2.2.0
  • Status changed from new to assigned

need to reproduce

comment:3 Changed 18 months ago by moo

  • Milestone changed from 4.0.0 to 3.0.2
  • Resolution set to fixed
  • Status changed from assigned to closed

this bug should have been fixed in some previous versions

Note: See TracTickets for help on using tickets.