Opened 6 years ago

Closed 6 years ago

Last modified 21 months ago

#138 closed defect (fixed)

Crash with long xcache.mmap_path

Reported by: judas_iscariote Owned by: moo
Priority: minor Milestone: 2.0.0
Component: cacher Version: 1.2.1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Always Blocked By:
Blocking:

Description

we have a crash with :

php -dxcache.mmap_path="/tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" -r 'echo "foo";'

SEGV on 0x00002ac028a2c9d8 in zm_post_zend_deactivate_xcache ()

in anycase xcache.mmap_path should not be longer than MAXPATHLEN

Change History (4)

comment:1 Changed 6 years ago by moo

  • Component changed from admin to cacher

comment:2 Changed 6 years ago by moo

  • Status changed from new to assigned

the problem is segv, "path too long" is a trigger only. we can either check path too long ourself or simply let syscall fail. the file name isn't important, but truncating it automatically might confuse the user if he want to know what file is in use.

comment:3 Changed 6 years ago by moo

  • Milestone changed from 1.3.0 to 2.0.0
  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in [516] in trunk. to be back merged

comment:4 Changed 21 months ago by moo

  • Milestone changed from 2.2.0 to 2.0.0
Note: See TracTickets for help on using tickets.