Opened 7 years ago

Closed 22 months ago

#123 closed defect (worksforme)

autoload malfunction

Reported by: glen Owned by: moo
Priority: minor Milestone:
Component: cacher Version: 1.2.1
Keywords: Cc:
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

(mod_fastcgi.c.2570) FastCGI-stderr: PHP Fatal error: Class 'field_uploaded_file' not found in /usr/share/photoproject/actions/picture_add_flash.php on line 121

there exists __autoload() function which will include classes/$classname.inc

class inheritance is:

+-- 14 lines: class field_uploaded_file extends field------------------------------------------------------------------------------------------------------
+--175 lines: class field----------------------------------------------------------------------------------------------------------------------------------

the temporary fix was to restart xcache.

Change History (5)

comment:1 Changed 7 years ago by judas_iscariote

  • pending changed from 0 to 1

can you provide reproduce code in order to fix the problem ?

comment:2 Changed 6 years ago by moo

  • Component changed from admin to cacher

comment:3 Changed 22 months ago by moo

  • Resolution set to worksforme
  • Status changed from new to closed

works for me in 2.0.1

comment:4 Changed 22 months ago by moo

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:5 Changed 22 months ago by moo

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.