Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#12 closed defect (fixed)

Apache 2.2.2 and PHP 5.1.4 support on Win32

Reported by: rele@… Owned by: moo
Priority: major Milestone: 1.0.1
Component: cacher Version: 1.0
Keywords: Apache, Win32 Cc: xcache.lighttpd.net@…
Application: PHP Version:
Other Exts: SAPI: Irrelevant
Probability: Blocked By:
Blocking:

Description

Every time I try to start the Apache service with activated XCache 1.0, the httpd.pid is created normally in the logs folder, but Apache does not start at all and the created httpd.pid remains.
There is nothing logged to error.log.

The net start command reports System Error 1067.

I tried both ways: zend_extension_ts and extension. They produce the same result.

As soon as I comment the extension out from php.ini, Apache can be started normally again (only a warning about the found pid file is written to error.log).

This behaviour is every time reproducable.

Best regards,
René Leonhardt

Change History (8)

comment:1 Changed 9 years ago by moo

  • Owner changed from somebody to moo
  • Status changed from new to assigned

confirmed. it was only tested with php fastcgi, win32 of course.

comment:2 Changed 9 years ago by anonymous

this affect ZTS only. workarround: make sure both xcache.size and xcache.var_size is non-zero

comment:3 Changed 9 years ago by moo

  • Resolution set to fixed
  • Status changed from assigned to closed

in [74], please try autobuild @ http://210.51.190.228/pub/XCache/win32autobuilds/

fell free to reopen if it's not fixed

comment:4 Changed 8 years ago by anonymous

Milestone milestone1 deleted

comment:5 Changed 8 years ago by moo

  • Milestone set to 1.0.1

comment:6 Changed 8 years ago by moo

  • Component changed from component1 to cacher

comment:7 Changed 6 years ago by c960657

  • Cc xcache.lighttpd.net@… added
  • pending set to 0
  • SAPI set to Irrelevant
     if (strcmp(sapi_module.name, "cli") == 0) {
         if ((env = getenv("XCACHE_TEST")) != NULL) {
             zend_alter_ini_entry("xcache.test", sizeof("xcache.test"), env, strlen(env) + 1, PHP_INI_SYSTEM, PHP_INI_STAGE_STARTUP);
         }
         if (!xc_test) {
             /* disable cache for cli except for test */
             xc_php_size = xc_var_size = 0;
         }
     }

+    xc_config_long(&xc_php_size,   "xcache.size",       "0");

Shouldn't the value of xcache.size have been inserted above the check for cli?

comment:8 Changed 6 years ago by moo

yeah, thanks. next time you should open a new ticket, btw

Note: See TracTickets for help on using tickets.