Custom Query (299 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (52 - 54 of 299)

Ticket Resolution Summary Owner Reporter
#21 invalid Apache start: xcache.so: undefined symbol: destroy_zend_function moo anonymous
Description

Hi,

I try to get Apache 2.2.2 with PHP 5.1.4 to run. Without xcache it works. Compiling xcache also works without complaints. But including xcache into php.ini results in this error at apache startup:

Failed loading /usr/local/LAMP/php/5.1.4/lib/php/extensions/no-debug-non-zts-20050922/xcache.so: /usr/local/LAMP/php/5.1.4/lib/php/ext ensions/no-debug-non-zts-20050922/xcache.so: undefined symbol: destroy_zend_function

my configuration of xcache:

  1. /usr/local/LAMP/php/5.1.4/bin/phpize --clean
  2. /usr/local/LAMP/php/5.1.4/bin/phpize
  3. ./configure --prefix=/usr/local/LAMP/xcache/1.0 \

--with-php-config=/usr/local/LAMP/php/5.1.4/bin/php-config \ --enable-xcache

Best regards,

Christian

#29 invalid win32 error - Invalid argument moo anonymous
Description

Hi all,

i have tried to install XCache-trunk-php-5.1.4-Win32-20060814060520 win32autobuild on Apache/2.2.2 (Win32) / PHP/5.1.4 (Apache 2.0 Handler) and: nothing:

apache error.log:

[Mon Aug 14 13:09:02 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Aug 14 13:09:02 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon Aug 14 13:09:03 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Aug 14 13:09:03 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon Aug 14 13:23:15 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Aug 14 13:23:15 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon Aug 14 13:23:15 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Aug 14 13:23:15 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null

php.ini:

[xcache-common]
zend_extension_ts = "\xampp\php\extensions\php_xcache.dll"
auto_globals_jit = Off

[xcache.admin]
xcache.admin.user = "mOo"
xcache.admin.pass = ""

[xcache]
xcache.size =                  8M
xcache.count =                 1
xcache.slots =                 8K
xcache.var_size =              8M
xcache.var_count =             1
xcache.var_slots =             8K
xcache.test =                  Off
xcache.readonly_protection =   Off
xcache.mmap_path =    "\xampp\tmp"
xcache.coredump_directory =   "\xampp\tmp"
xcache.cacher =                On
xcache.optimizer =             Off

[xcache.coverager]
xcache.coveragedumper         = Off

Thanks for helping me.

Carlo

#119 worksforme xcache 1.2.1 has problems together with zend optimizer 3.3.0 moo anonymous
Description

In the admin page, the compile is always set to "yes" and the clogging number keeps increasing. It seems that it stucks with one of the zend optimizer code.

I removed the zend optimizer from the php.ini, then the xcache works fine

-sh-3.00$ php-cgi -v PHP 5.2.3 (cgi-fcgi) (built: Jun 18 2007 17:33:40) Copyright (c) 1997-2007 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

with XCache v1.2.1, Copyright (c) 2005-2007, by mOo with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies

Note: See TracQuery for help on using queries.